CVE-2014-7290
CVSS4.3
发布时间 :2014-11-19 10:59:00
修订时间 :2017-09-07 21:29:16
NMCPS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Atlas Systems Aeon 3.5 and 3.6 allow remote attackers to inject arbitrary web script or HTML via the (1) Action or (2) Form parameter to aeon.dll.


[CNNVD]Atlas Systems Aeon 跨站脚本漏洞(CNNVD-201411-344)

        

Atlas Systems Aeon是美国Atlas Systems公司的一套工作流程自动化软件。该软件提供项目跟踪、数据统计等功能。

Atlas Systems Aeon 3.5版本和3.6版本中存在跨站脚本漏洞,该漏洞源于aeon.dll文件没有充分过滤‘Action’和‘Form’参数。远程攻击者可利用该漏洞注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:atlas_systems:aeon:3.6
cpe:/a:atlas_systems:aeon:3.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-7290
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2014-7290
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-201411-344
(官方数据源) CNNVD

- 其它链接及资源

http://packetstormsecurity.com/files/129114/Atlas-Systems-Aeon-3.5-3.6-Cross-Site-Scripting.html
(UNKNOWN)  MISC  http://packetstormsecurity.com/files/129114/Atlas-Systems-Aeon-3.5-3.6-Cross-Site-Scripting.html
http://seclists.org/fulldisclosure/2014/Nov/32
(UNKNOWN)  FULLDISC  20141114 CVE-2014-7290 Atlas Systems Aeon XSS (Cross-Site Scripting) Vulnerability
http://tetraph.com/security/xss-vulnerability/cve-2014-7290-atlas-systems-aeon-xss-cross-site-scripting-vulnerability/
(UNKNOWN)  MISC  http://tetraph.com/security/xss-vulnerability/cve-2014-7290-atlas-systems-aeon-xss-cross-site-scripting-vulnerability/
https://exchange.xforce.ibmcloud.com/vulnerabilities/98705
(UNKNOWN)  XF  atlassystemsaeon-cve20147290-xss(98705)

- 漏洞信息

Atlas Systems Aeon 跨站脚本漏洞
中危 跨站脚本
2014-11-20 00:00:00 2014-11-20 00:00:00
远程  
        

Atlas Systems Aeon是美国Atlas Systems公司的一套工作流程自动化软件。该软件提供项目跟踪、数据统计等功能。

Atlas Systems Aeon 3.5版本和3.6版本中存在跨站脚本漏洞,该漏洞源于aeon.dll文件没有充分过滤‘Action’和‘Form’参数。远程攻击者可利用该漏洞注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
        http://www.atlas-sys.com/aeon/

- 漏洞信息 (F129114)

Atlas Systems Aeon 3.5 / 3.6 Cross Site Scripting (PacketStormID:F129114)
2014-11-14 00:00:00
Jing Wang  
exploit,xss
CVE-2014-7290
[点击下载]

Atlas Systems Aeon versions 3.5 and 3.6 suffer from a cross site scripting vulnerability.

CVE-2014-7290  Atlas Systems Aeon XSS (Cross-Site Scripting) Vulnerability


Exploit Title: Atlas Systems Aeon XSS Vulnerability
Product: Aeon
Vendor: Atlas Systems
Vulnerable Versions: 3.6 3.5
Tested Version: 3.6
Advisory Publication: Nov 12, 2014
Latest Update: Nov 12, 2014
Vulnerability Type: Cross-Site Scripting [CWE-79]
CVE Reference: CVE-2014-7290
Solution Status: Fixed by Vendor
Credit: Wang Jing [Mathematics, Nanyang Technological University, Singapore]





Advisory Details:

(1) Aeon

Aeon is special collections circulation and workflow automation software
for your special collections library designed by special collections
librarians.

Aeon improves customer service and staff efficiency while providing
unparalleled item tracking, security and statistics.



(2) However, it is vulnerable to XSS Attacks.

(2.1) The first vulnerability occurs at "aeon.dll?" page, with "&Action"
parameter.
(2.2) The second vulnerability occurs at "aeon.dll?" page, with "&Form"
parameter.




Solutions:
2014-09-01: Report vulnerability to Vendor
2014-10-05: Vendor replied with thanks and vendor will change the source
code





References:
http://tetraph.com/security/xss-vulnerability/cve-2014-7290-atlas-systems-aeon-xss-cross-site-scripting-vulnerability/
https://prometheus.atlas-sys.com/display/aeon/Aeon+3.6+Release+Notes
http://cwe.mitre.org
http://cve.mitre.org/


    

- 漏洞信息

Atlas Systems Aeon 'aeon.dll?' Multiple Cross Site Scripting Vulnerabilities
Input Validation Error 71185
Yes No
2014-11-13 12:00:00 2014-11-13 12:00:00
Jing Wang

- 受影响的程序版本

- 漏洞讨论

Atlas Systems Aeon is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input.

An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks.

Aeon versions 3.5 and 3.6 are vulnerable; other versions may also be affected.

- 漏洞利用

Attackers can exploit these issues by enticing an unsuspecting victim to follow a malicious URI.

- 解决方案

Currently, we are not aware of any vendor-supplied patches. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站